Update Cocoapods 1.1.1

工具集,iOS开发,question 归纳笔记

Posted by oragekk on November 9, 2016

之前采用正常的 sudo gem install cocoapods更新cocoapods版本一直不成功,下面为和我遇到同样问题的兄弟们提供一个解决办法

先切换gem源

  • gem sources --remove https://rubygems.org/
  • gem source -a https://gems.ruby-china.org
  • 查看是否切换成功 gem source -l 如果出现下图这样的就说明切换成功了, 如果还是官方的源, 请手动重启电脑尝试

接下来就可以开始升级了cocoapods了

  • sudo gem install -n /usr/local/bin cocoapods --pre
  • 是的, 你没看错是这个命令, 然后终端会出现一大推东西, 别管他, 最后停下来是这样的就差不多了
  • 然后查看版本pod --version 出现1.1.1,恭喜你已经安装成功了
  • 接下来设置pod仓库 pod setup

Paste_Image.png 此处需要耐心等待,根据网络情况完成时间长短不一。 可以在终端中CD到~/.cocoapods目录中输入 du -sh *查看下载进度

至此, 已经升级到cocoapods1.1.1了, 可以愉快的把玩Swift3.0的一些三方库了